const regex = /^(?<ip_addr>((\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|((([\da-fA-F]{1,4}:){7})([\da-fA-F]{1,4})$|(([\da-fA-F]{1,4}:){1,6}:)(([\da-fA-F]{1,4}:){0,4})([\da-fA-F]{1,4}))|(::[\da-fA-F]{1,4})|(([\da-fA-F]{1,4}:){0,7}[\da-fA-F]{1,4}::)))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<ip_addr>((\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})|((([\\da-fA-F]{1,4}:){7})([\\da-fA-F]{1,4})$|(([\\da-fA-F]{1,4}:){1,6}:)(([\\da-fA-F]{1,4}:){0,4})([\\da-fA-F]{1,4}))|(::[\\da-fA-F]{1,4})|(([\\da-fA-F]{1,4}:){0,7}[\\da-fA-F]{1,4}::)))$', 'mg')
const str = `1.2.3.4
01.02.3.4
01.02.03.04
128.101.1.1
128.1.101.101
987.654.321.0
2607:ea00:101:102:103:104:105:106
2607:eA00:abcd:efab:cDeF:0000:0000:0001
fe80::64
ff02::
::1
2001:468::
2001::468::4
:::1
2001:410:::
123.123.1a3.313
1.2.3.
.2.3.4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}