const regex = new RegExp('^(join|j) https://discord\\.gg/([A-Za-z0-9]+)$', 's')
const str = `join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}