import re
regex = re.compile(r"^(join|j) https://discord\.gg/([A-Za-z0-9]+)$", flags=re.DOTALL)
test_str = "join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")