$re = '/\B#\w+/';
$str = 'This is a #hashtag, and this is #another one!
google.com#tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);