using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])|(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])(\/([1-9]?\d|1\d\d|2[0-4]\d|25[0-5]))))$";
string input = @"1.1.1.142
128.12.34.9
0.0.0.0/128
1.1.1.1
13.23.76.90/128";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}