import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.0*(([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])|(([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])(\\/([1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5]))))$";
final String string = "1.1.1.142\n"
+ "128.12.34.9\n"
+ "0.0.0.0/128\n"
+ "1.1.1.1\n"
+ "13.23.76.90/128";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}