re = /^0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])\.0*(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])|(([1-9]?\d|1\d\d|2[0-4]\d|25[0-5])(\/([1-9]?\d|1\d\d|2[0-4]\d|25[0-5]))))$/m
str = '1.1.1.142
128.12.34.9
0.0.0.0/128
1.1.1.1
13.23.76.90/128'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end