package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a\s+[^>]+>)`)
var str = `<a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png"><img class="alignnone size-full wp-image-11943" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg" alt="work-essentials-1" width="440" height="150" /></a><a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png"><img class="alignnone size-full wp-image-11944" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg" alt="work-essentials-2" width="440" height="150" /></a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}