const regex = new RegExp('(<a\\s+[^>]+>)', 'gm')
const str = `<a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png"><img class="alignnone size-full wp-image-11943" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg" alt="work-essentials-1" width="440" height="150" /></a><a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png"><img class="alignnone size-full wp-image-11944" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg" alt="work-essentials-2" width="440" height="150" /></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}