const regex = /<\s*script\s+.*?src\s*=\s*['"]?([^'"?# ]+).*?><\s*\/\s*script\s*>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*script\\s+.*?src\\s*=\\s*[\'"]?([^\'"?# ]+).*?><\\s*\\\/\\s*script\\s*>', '')
const str = `<script type="text/javascript" src='bower_components/gsap/src/minified/TweenMax.min.js'> </script>
<script src='bower_components/gsap/src/minified/TweenMax.min.js'></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}