// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*script\s+.*?src\s*=\s*['"]?([^'"?# ]+).*?><\s*\/\s*script\s*>"#).unwrap();
let string = "<script type=\"text/javascript\" src='bower_components/gsap/src/minified/TweenMax.min.js'> </script>
<script src='bower_components/gsap/src/minified/TweenMax.min.js'></script>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}