import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(US|UK|FR)|(CA|NY|IA|TX|MI)|(\\d+\\/\\d+)|\\(((.+?)\\s+([0-9]+))\\)|([A-Z][a-z]{2,}|[A-Z]{3,})|(.*?)";
final String string = "US 7/70 MI Construction hrs.\n"
+ "US IA Private hrs.\n"
+ "US OIL 8/70 hrs. (Dec 2014)\n"
+ "UK 7/70 MI Construction hrs.\n"
+ "UK IA Private hrs.\n"
+ "UK OIL 8/70 hrs. (Dec 2014)\n"
+ "FR 7/70 MI Construction hrs.\n"
+ "FR IA Private hrs.\n"
+ "FR OIL 8/70 hrs. (Dec 2014)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}