use strict;
my $str = 'valid.email@example.com
john.doe123@example.co.uk
alice_smith@company.org
user1234@emailprovider.net
test.email1234@email-domain.com
support@website.info
jane.doe@emailprovider.org
contact_us123@example.net
my.email123@email-provider.co
a@ce.ce
invalid.email@missingtld
john.doe@invaliddomain.c
spaces in@email.com
special!chars@email.com
noatemail.com
double..dots@email.com
@missingusername.com
user@inva@lid.com
missingatsigndomain.com';
my $regex = qr/(((([a-zA-Z0-9]{2,255})+[/.]|([a-zA-Z0-9]{2,255})+[/_]|([a-zA-Z0-9]{2,255})+[/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+@(((([a-zA-Z0-9]{2,255})+[/.]|([a-zA-Z0-9]{2,255})+[/_]|([a-zA-Z0-9]{2,255})+[/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+\.[a-z]{2,64}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}