# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a\h+href=(['"])\1>([^<>]*)<\\/a>/$2/gm;t' <<< "this is a bet and he is <a href=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>"