use strict;
my $str = 'this is a bet and he is <a href=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a href=\'\'>Yammy</a>';
my $regex = qr/<a\h+href=(['"])\1>([^<>]*)<\/a>/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";