$re = '/<a\h+href=([\'"])\1>([^<>]*)<\/a>/m';
$str = 'this is a bet and he is <a href=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a href=\'\'>Yammy</a>';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;