package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$[^\$]++\$`)
var str = `1 [00:00:12.00 - 00:01:20.00] Hello there - I've come to help you.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}