re = /\$[^\$]++\$/m
str = '1 [00:00:12.00 - 00:01:20.00] Hello there - I\'ve come to help you.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end