using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!\w)((?:north|south)?(?:east|west)?)\b(?!\w)";
string input = @"The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}