re = /\b(?<!\w)((?:north|south)?(?:east|west)?)\b(?!\w)/m
str = 'The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end