// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\w+\W+){4}([A-Z]{3,})(?:\W+\w+){4}").unwrap();
let string = "Lorem ASPIRE dolor sit amet, consectetur adipiscing elit. ASPIRE finibus mauris quis tortor commodo, ut placerat sapien pellentesque. Interdum et malesuada ASPIRE ac ante ipsum primis in faucibus. Proin efficitur purus eu varius AB. Sed congue dui sit amet aliquet tempor. Praesent sit amet ABC velit, nec rhoncus elit. Curabitur eget magna elementum, porttitor metus tincidunt, semper turpis. Curabitur a ante tristique, hendrerit leo malesuada, mattis arcu. Fusce nec ultricies dolor, nec aliquet ASPIRE. Morbi tempor vel dolor sed varius. Vestibulum non ipsum ultrices, egestas nulla lobortis, fringilla nisi. Phasellus commodo tristique dolor eu dictum. Phasellus orci risus, dignissim eget tortor at, tincidunt ASPIRE est. Nunc eget tellus ut diam vestibulum laoreet sed ASPIRE odio.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}