import Foundation
let pattern = #"(?:\w+\W+){4}([A-Z]{3,})(?:\W+\w+){4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Lorem ASPIRE dolor sit amet, consectetur adipiscing elit. ASPIRE finibus mauris quis tortor commodo, ut placerat sapien pellentesque. Interdum et malesuada ASPIRE ac ante ipsum primis in faucibus. Proin efficitur purus eu varius AB. Sed congue dui sit amet aliquet tempor. Praesent sit amet ABC velit, nec rhoncus elit. Curabitur eget magna elementum, porttitor metus tincidunt, semper turpis. Curabitur a ante tristique, hendrerit leo malesuada, mattis arcu. Fusce nec ultricies dolor, nec aliquet ASPIRE. Morbi tempor vel dolor sed varius. Vestibulum non ipsum ultrices, egestas nulla lobortis, fringilla nisi. Phasellus commodo tristique dolor eu dictum. Phasellus orci risus, dignissim eget tortor at, tincidunt ASPIRE est. Nunc eget tellus ut diam vestibulum laoreet sed ASPIRE odio."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)