package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)account_id\\\":\\\"(?<account_id>[^\\]+)`)
var str = `"message":"sypher:[tokenized] build successful -\xxxxy {\"data\":{\"account_id\":\"ABC123XYZ\",\"activity\":{\"time\":\"2024-05-31T12:37:25Z\}}"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}