const regex = /account_id\\\":\\\"(?<account_id>[^\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('account_id\\\\\\":\\\\\\"(?<account_id>[^\\\\]+)', 'gm')
const str = `"message":"sypher:[tokenized] build successful -\\xxxxy {\\"data\\":{\\"account_id\\":\\"ABC123XYZ\\",\\"activity\\":{\\"time\\":\\"2024-05-31T12:37:25Z\\}}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}