$re = '/account_id\\\\\":\\\\\"(?<account_id>[^\\\\]+)/m';
$str = '"message":"sypher:[tokenized] build successful -\\xxxxy {\\"data\\":{\\"account_id\\":\\"ABC123XYZ\\",\\"activity\\":{\\"time\\":\\"2024-05-31T12:37:25Z\\}}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);