import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<host>[^\\s]+) (?P<ip>[^\\s]+) (?P<server>[^\\s]+) - (?P<date>[^\\s+]+) (?P<timezone>[^\\s]+) \"(?P<method>[^\\s]+) (?P<url>[^\\s]+) HTTP\\/\\d.\\d\" (?P<response>[^\\s]+) (?P<size>[^\\s]+) (?P<referrer>[^\\s]+) \"(?P<agent>.+)\"\\n";
final String string = "www.kurufootwear.com 107.72.164.97 54.197.85.60 - 2016-12-25T00:00:00Z 0.064 \"GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g2.jpg HTTP/1.1\" 200 1730 74999 \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1\"\n\n"
+ "www.kurufootwear.com 107.72.164.97 52.3.240.70 - 2016-12-25T00:00:00Z 0.066 \"GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g3.jpg HTTP/1.1\" 200 1730 76243 \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}