# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<host>[^\s]+) (?P<ip>[^\s]+) (?P<server>[^\s]+) - (?P<date>[^\s+]+) (?P<timezone>[^\s]+) \"(?P<method>[^\s]+) (?P<url>[^\s]+) HTTP\/\d.\d\" (?P<response>[^\s]+) (?P<size>[^\s]+) (?P<referrer>[^\s]+) \"(?P<agent>.+)\"\n"
test_str = ("www.kurufootwear.com 107.72.164.97 54.197.85.60 - 2016-12-25T00:00:00Z 0.064 \"GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g2.jpg HTTP/1.1\" 200 1730 74999 \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1\"\n\n"
"www.kurufootwear.com 107.72.164.97 52.3.240.70 - 2016-12-25T00:00:00Z 0.066 \"GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g3.jpg HTTP/1.1\" 200 1730 76243 \"Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1\"")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.