import Foundation
let pattern = #"^(?P<host>[^\s]+) (?P<ip>[^\s]+) (?P<server>[^\s]+) - (?P<date>[^\s+]+) (?P<timezone>[^\s]+) "(?P<method>[^\s]+) (?P<url>[^\s]+) HTTP\/\d.\d" (?P<response>[^\s]+) (?P<size>[^\s]+) (?P<referrer>[^\s]+) "(?P<agent>.+)"\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
www.kurufootwear.com 107.72.164.97 54.197.85.60 - 2016-12-25T00:00:00Z 0.064 "GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g2.jpg HTTP/1.1" 200 1730 74999 "Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1"
www.kurufootwear.com 107.72.164.97 52.3.240.70 - 2016-12-25T00:00:00Z 0.066 "GET /media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/1/0/100911-g3.jpg HTTP/1.1" 200 1730 76243 "Mozilla/5.0 (iPhone; CPU iPhone OS 10_2 like Mac OS X) AppleWebKit/602.3.12 (KHTML, like Gecko) Version/10.0 Mobile/14C92 Safari/602.1"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}