package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([_]{1,})$`)
var str = `_asd
a_
__
_asd_
a__
_
asd asd a __ asd asd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}