$re = '/^([_]{1,})$/m';
$str = '_asd
a_
__
_asd_
a__
_
asd asd a __ asd asd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);