# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http:\\/\\/example\.com\\/.*?\\/.*?\\/.*?)\.png/$1.jpg/g;t' <<< "bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text\"\"http://example.com/2016/10/26001140/blah.png@@more_text"