const regex = /(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/example\\.com\\\/.*?\\\/.*?\\\/.*?)\\.png', 'g')
const str = `bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text`;
const subst = `$1.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);