#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)951\d+"
Local $sString = "95168372685" & @CRLF & _
"95268372685" & @CRLF & _
"9518573" & @CRLF & _
"23456789" & @CRLF & _
"95199838995" & @CRLF & _
"95335363647" & @CRLF & _
"951123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")