$re = '/951\d+/m';
$str = '95168372685
95268372685
9518573
23456789
95199838995
95335363647
951123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);