import re
regex = re.compile(r"^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Matches containing some directory names, \n"
"but what about the oposite? having \"good|big|aproved\" directorys? and then hiding the others?\n"
"16x16\n"
"20x20\n"
"250x250\n"
"50x50\n"
"flobee\n"
"x\n"
"xx\n"
"abc/cdr\n"
"--> to hide >-- \n"
"16x16/xxxx\n"
"/16x16/xxxx\n"
"path/16x16/xxxx\n"
"250x250/xxxx\n"
"/250x250/xxxx\n"
"good/16x16/xxxx\n"
"/good/16x16/xxxx\n"
"big/16x16/xxxx\n"
"/big/16x16/xxxx\n"
"--< to hide <-- \n\n"
"good/xxxx\n"
"/good/xxxx\n"
"big/xxxx\n"
"/big/xxxx\n"
"/a/b/c/xxx.file\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")