import Foundation
let pattern = #"^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Matches containing some directory names,
but what about the oposite? having "good|big|aproved" directorys? and then hiding the others?
16x16
20x20
250x250
50x50
flobee
x
xx
abc/cdr
--> to hide >--
16x16/xxxx
/16x16/xxxx
path/16x16/xxxx
250x250/xxxx
/250x250/xxxx
good/16x16/xxxx
/good/16x16/xxxx
big/16x16/xxxx
/big/16x16/xxxx
--< to hide <--
good/xxxx
/good/xxxx
big/xxxx
/big/xxxx
/a/b/c/xxx.file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)