using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@example\.org$";
string input = @"alice@example.org
eve@evil.us
bob@example.org";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}