$re = '`@example\.org$`m';
$str = 'alice@example.org
eve@evil.us
bob@example.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);