package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@example\.org$`)
var str = `alice@example.org
eve@evil.us
bob@example.org`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}