using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*company_name:\s*(.*\D)\s*(\w.*)";
string input = @"sentences
company_name: company, ltd6
numbers 99 and letters 99 (I want to match anything here)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}