$re = '/.*company_name:\s*(.*\D)\s*(\w.*)/m';
$str = 'sentences
company_name: company, ltd6
numbers 99 and letters 99 (I want to match anything here)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);