re = /.*company_name:\s*(.*\D)\s*(\w.*)/m
str = 'sentences
company_name: company, ltd6
numbers 99 and letters 99 (I want to match anything here)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end