import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "LIST\\d+ LIST\\d+\\R((?!$)\\S*(?: +\\S+)?(?:\\R|\\Z))*?(?:(?:(\\S+) +(?:\\S*\\R(?1)*\\S* +)?\\2\\b\\R?)|(?:\\S+ (\\S+)\\R(?1)*\\3\\b))(?1)*";
final String string = "LIST1 LIST2\n"
+ "item1 item2\n"
+ "item3 item4\n"
+ "item5 item6\n\n"
+ "LIST3 LIST4\n"
+ "item1 item2\n"
+ "item4\n"
+ "item2\n\n"
+ "LIST5 LIST6\n"
+ "item1 item3\n"
+ "item2 item4\n"
+ "item5 item2\n\n"
+ "LIST7 LIST8\n"
+ "item1 itemA\n"
+ "item2 itemB\n"
+ "item3 itemC\n"
+ " itemD\n"
+ " item3\n"
+ " itemE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}