import Foundation
let pattern = #"LIST\d+ LIST\d+\R((?!$)\S*(?: +\S+)?(?:\R|\Z))*?(?:(?:(\S+) +(?:\S*\R(?1)*\S* +)?\2\b\R?)|(?:\S+ (\S+)\R(?1)*\3\b))(?1)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LIST1 LIST2
item1 item2
item3 item4
item5 item6
LIST3 LIST4
item1 item2
item4
item2
LIST5 LIST6
item1 item3
item2 item4
item5 item2
LIST7 LIST8
item1 itemA
item2 itemB
item3 itemC
itemD
item3
itemE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)