const regex = /\"assets\/styles\/app-+.*\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"assets\\\/styles\\\/app-+.*\\"', '')
const str = `<link rel="stylesheet" href="assets/styles/app-be0aad6b31.css">`;
const subst = `$0 media="screen"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);