import Foundation
let pattern = #"\"assets\/styles\/app-+.*\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<link rel="stylesheet" href="assets/styles/app-be0aad6b31.css">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0 media="screen""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}