$re = '/\"assets\/styles\/app-+.*\"/';
$str = '<link rel="stylesheet" href="assets/styles/app-be0aad6b31.css">';
$subst = "$0 media=\"screen\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;