const regex = /^(?:[A-Z]{2,}(?:[^A-Za-z\r\n]|[A-Za-z](?![a-z]))*)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Z]{2,}(?:[^A-Za-z\\r\\n]|[A-Za-z](?![a-z]))*)+$', 'gm')
const str = `THE QUEEN’S HAND
THE QUEEN’s HAND
THE QUEEN’ss HAND
THE QUEEN’sAAs HAND`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}