import re
regex = re.compile(r"^(?:[A-Z]{2,}(?:[^A-Za-z\r\n]|[A-Za-z](?![a-z]))*)+$", flags=re.MULTILINE)
test_str = ("THE QUEEN’S HAND\n"
"THE QUEEN’s HAND\n"
"THE QUEEN’ss HAND\n"
"THE QUEEN’sAAs HAND")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")