$re = '/^(?:[A-Z]{2,}(?:[^A-Za-z\r\n]|[A-Za-z](?![a-z]))*)+$/m';
$str = 'THE QUEEN’S HAND
THE QUEEN’s HAND
THE QUEEN’ss HAND
THE QUEEN’sAAs HAND';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);